Resolved: The maintenance window has been completed
Identified: We are installing a brand new release of Test Track that includes new features such as automated test runs and flaky test detection along with a whole new UI. We are performing the upgrade from Friday 8th March 2024 at 22:00 GMT. During this time, we do not expect any downtime.